Attribute error while running the ER_CMD# commands

Post any general questions you may have here and we will endeavor to answer them as best we can.

Moderators: radiomadeeasy, WirelessMike

Attribute error while running the ER_CMD# commands

Postby samiulsaki » Fri Feb 05, 2016 2:18 am

I have two connect2pi modules on two raspberry Pis. I did the
Code: Select all
sudo apt-get dist-upgrade
and after that I can see my device attached to ttyUSB0. That means I don't had to install FTDI driver for the pis. Then I did install python-setuptools and and install module into python 2.x.
Then I tried to run the script it it runs but when I ran a command (eg. ER_CMD#T3) it started to give me Traceback (most recent call last) .........AttributeError: 'Serial' object has no attribute 'outWaiting'.
I did some research on it and change the file name to as that seems to fix it for some people. This started to give me the ser = serial.Serial(
AttributeError: 'module' object has no attribute 'Serial'
Then I added from serial import serial since someone suggested that we are importing a module not a class. This gives me the error ImportError: cannot import name serial.

Seems like if I change the name to it gives me the Attributeerror with has no attribute 'outwaiting'. And if I name it to then it gives Attributerror with module has no attribute serial.

I tried to run one of the module with windows 7 and other one attached to raspberry Pi. But I don't get any ACK back when I try to send 5 bytes by using Easyradio v4.0.5.

I am using Raspbian Wheezy, Linux version 4.1.13+. Both connect2pi modules and raspberrys has 9600 baudrate. Both modules are set to exactly same configuration.
I might doing something wrong. Can you help me out with this problem with a bit of instruction please. Any help will be appreciated. Thanks in advance.

Posts: 0
Joined: Tue Jan 19, 2016 12:42 am

Return to General Technical Support

Who is online

Users browsing this forum: No registered users and 0 guests